Subscribe to updates
Powered by
OCR
Resolved
·
Degraded performance
All OCR system operational
Sun, Mar 1, 2026, 04:09 AM
(
1
month ago)
·
View all updates
Affected components
Feb 26, 2026, 02:19 PM
Feb 27, 2026, 04:00 PM
Optical Character Recognition (OCR) Based Service
Updates
Resolved
All OCR system operational
Sun, Mar 1, 2026, 04:09 AM
Identified
Error is identified on:
OCR
Thu, Feb 26, 2026, 02:19 PM
(
2
days earlier)
OCR - Verihubs Service Status