No components marked as affected
Resolved
BIOMETRIC service has been resolved. All systems are operating normally. We apologize for the disruption and thank you for your patience.
Investigating
We are currently experiencing an issue with our OCR service. Our engineering team has been notified and is actively investigating...